IC-R5 scanner - icr5cloner programming software

Frequently asked questions.

Got a question? This is the best place to check first!
Post Reply
Posts: 10
Joined: Sun Mar 30, 2008 8:15 pm

IC-R5 scanner - icr5cloner programming software

Post by IanK » Tue Jan 04, 2011 9:45 am


I have an Icom IC-R5 scanner and use icr5cloner programming software to change setings as doing it manually is a real pain.

For some reason I now get the following error when i try and use the software to Read/write to the radio

"Run-time error '339'
Component 'MSCOMM32.OCX' or one of its dependencies not correctly registered: a file is missing or invalid.

I have it on PC's with the following O/S's

Windows 7

All give the same result

I have tried contacting the original supplier but no response

Any body any ideas or does anybody have a copy of thi software they could send me incase my version is corrupted

I still have a the key I used when I first purchased it


Ian K

Posts: 3081
Joined: Sat Feb 09, 2008 10:06 am
Amateur callsign: VK6UFO_VK6RN
Scanners and Receivers:  
Diamond Welz WS1000 wideband handheld
Radioshack Pro 28 handheld
Uniden UBC72XLT handheld
Uniden UBC73XLT handheld
Uniden UBC330CRS desktop

Yaesu VX-3R 2m/70cm Ham TRX and wideband RX handheld
Yaesu FT-1802M 2m Ham TRX mobile x 2
Yaesu FT-7800R 2m/70cm Ham TRX and wide band RX mobile
Icom IC-208H 2m/70cm Ham TRX and wide band RX mobile
Icom IC-706MKIIG all-band all-mode Ham TRX mobile
Icom IC-V85 2m VHF Ham TRX handheld
Wouxun KG-UVD1P VHF/UHF wideband Ham TRX handheld
Wouxun KG-679P VHF wideband Ham TRX handheld
Wouxun KG-713 UHF wideband Ham TRX handheld
Location: Just on the border of your waking mind

Re: IC-R5 scanner - icr5cloner programming software

Post by robbage » Tue Jan 04, 2011 10:34 am

That's a classic error report from a Visual Studio program. It means that MSCOMM32.OCX has probably been deleted or damaged. If the program came as an installer then it should be fixed by re-installing it.
MSCOMM32.OCX is the activex component that allows communications over a serial port.
If it still doesn't work after re-installing it, send me a PM.
 Amateur moderator
Arguing with a fool proves there are two

Post Reply